<URL: http://bugs.freeciv.org/Ticket/Display.html?id=39585 >

Forwarded from http://forum.freeciv.org/viewtopic.php?p=16663#16663
___________________________________________________________

Hi i downloaded svn trunk tree and after

./autogen.sh --enable-client=sdl
make

i start getting many warnings and then following errors :

dialogs.c: In function 'popup_government_dialog':
dialogs.c:1984: warning: implicit declaration of function 'government_interate'
dialogs.c:1984: error: 'pGov' undeclared (first use in this function)
dialogs.c:1984: error: (Each undeclared identifier is reported only once
dialogs.c:1984: error: for each function it appears in.)
dialogs.c:1984: error: expected ';' before '{' token
dialogs.c:1961: warning: unused variable 'max_h'
dialogs.c:1961: warning: unused variable 'max_w'
dialogs.c:1958: warning: unused variable 'pGov_Button'
dialogs.c:1956: warning: unused variable 'pLogo'
dialogs.c: At top level:
dialogs.c:2005: error: expected identifier or '(' before '}' token
dialogs.c:2005: error: expected identifier or '(' before '}' token
dialogs.c:2007: error: expected '=', ',', ';', 'asm' or '__attribute__'
.
.
.
make[3]: *** [dialogs.o] Error 1
make[3]: Leaving directory `/root/freeciv/client/gui-sdl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/freeciv/client'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/freeciv'
make: *** [all] Error 2


I've read Install and downloaded with synaptic tha sdl ,sdl-image libraries.
Any suggestion/help will be welcomed

thanks ,

Chomwitt (freeciv greek translator)



_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to