<URL: http://bugs.freeciv.org/Ticket/Display.html?id=40000 >
As revealed in PR#39960, most GAME_INFO packets are sent to update the
number of players! That really isn't a good use of this packet.
Instead, rename PLAYER_REMOVE to PLAYER_COUNT_UPDATE, and send for both
increases and decreases in the number of players.
Complete the removal of scattered references to game.info.nplayers.
Freeciv-dev mailing list