<URL: http://bugs.freeciv.org/Ticket/Display.html?id=40250 >

2008/5/24 Daniel Markstedt:
>
> $subject
>
> OSX 10.3.9
>
> ibg3:~/freeciv-2.1 daniel$ ./autogen.sh + checking for autoconf >=
> 2.55 ... found 2.57, ok.+ checking for autoheader >= 2.55 ... found
> 2.57, ok.
> + checking for automake >= 1.6 ... found 1.6.3, ok.
> + checking for aclocal >= 1.6 ... found 1.6.3, ok.

 I try to setup autoconf 2.57 + automake 1.6.3 environment for myself.
This seems to be either problem with those versions or your local
problem. Has anybody else reproduced this?

> + checking for xgettext >= 0.10.36 ... found 0.14.5, ok.
> + checking for msgfmt >= 0.10.36 ... found 0.14.5, ok.
> + running aclocal ...
> + running autoheader ...
> + running autoconf ...
> configure.ac:62: error: possibly undefined macro: AC_MSG_ERROR
>      If this token and others are legitimate, please use m4_pattern_allow.
>      See the Autoconf documentation.
> configure.ac:204: error: possibly undefined macro: AC_CHECK_LIB
> configure.ac:381: error: possibly undefined macro: AC_CHECK_HEADER
>
> autoconf failed

 Are m4_includes produced correctly to the end of aclocal.m4:

m4_include([m4/auth.m4])
m4_include([m4/c99.m4])
m4_include([m4/compiler.m4])
m4_include([m4/debug.m4])
m4_include([m4/freetype2.m4])
m4_include([m4/gettimeofday.m4])
m4_include([m4/ggz.m4])
m4_include([m4/glib-gettext.m4])
m4_include([m4/gtk-2.0.m4])
m4_include([m4/gtk2-client.m4])
m4_include([m4/iconv.m4])
m4_include([m4/locale.m4])
m4_include([m4/ngettext.m4])
m4_include([m4/no-client.m4])
m4_include([m4/pkg.m4])
m4_include([m4/readline.m4])
m4_include([m4/sdl-client.m4])
m4_include([m4/sdl.m4])
m4_include([m4/sound.m4])
m4_include([m4/vsnprintf.m4])
m4_include([m4/win32-client.m4])
m4_include([m4/x.m4])
m4_include([m4/xaw-client.m4])


 - ML



_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to