<URL: http://bugs.freeciv.org/Ticket/Display.html?id=40430 >

This is an error in ggz.m4 but I don't know quite where.

The intended behavior is:

* libggz and ggzcore and ggzmod >= 0.0.14 are required for client
support.  If --with-ggz-client=yes is given, configure exits if they are
not found; otherwise client support simply isn't compiled in.

* libggz and ggzdmod >= 0.99.4 are required for server support.  If
--with-ggz-server=yes is given, configure exits if they are not found;
otherwise server support simply isn't compiled in.

What appears to happen is that the first check for 0.0.14 finds it,
causing client support to succeed.  The following check for 0.99.4 then
also succeeds, even though 0.99.4 is not present, and this is what I
don't understand.

I think josef needs to look at ggz.m4.

-jason


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to