URL:
  <http://gna.org/bugs/?15596>

                 Summary: SCRIPT_ASSERT should always be enabled
                 Project: Freeciv
            Submitted by: englabenny
            Submitted on: lördag 2010-03-13 den 14:30
                Category: general
                Severity: 3 - Normal
                Priority: 1 - Later
                  Status: None
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 2.2
         Discussion Lock: Any
        Operating System: None
         Planned Release: 

    _______________________________________________________

Details:

SCRIPT_ASSERT does not only assure invariants in freeciv's code, but will
test user code very day when new scenarios and rulesets are built.

Because of this we need these to be enabled in all compiled versions of
freeciv, especially the release versions. Any script situation that can crash
freeciv should be considered a major bug.





    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?15596>

_______________________________________________
  Meddelandet skickades via/av Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to