URL:
  <http://gna.org/bugs/?15821>

                 Summary: gtk client compiler warning
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Thursday 04/08/2010 at 17:32
                Category: None
                Severity: 3 - Normal
                Priority: 1 - Later
                  Status: None
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: TRUNK r17284
         Discussion Lock: Any
        Operating System: None
         Planned Release: 2.3.0

    _______________________________________________________

Details:

--enable-debug compilation of TRUNK (S2_2 is *not* affacted) gtk client
errors out:
client/gui-gtk-2.0/dialogs.c: In function 'popup_pillage_dialog':
client/gui-gtk-2.0/dialogs.c:371: error: array subscript is above array
bounds
client/gui-gtk-2.0/dialogs.c:371: error: array subscript is above array
bounds 

This was with 32bit Ubuntu Lucid Lynx (upcoming Ubuntu release). Cannot
reproduce with 64bit Debian Squeeze or 64bit Ubuntu Karmic Koala. I'll be
doing test compilations in more environments:
http://www.cazfi.net/freeciv/testing/compilation.php





    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?15821>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to