Follow-up Comment #4, bug #16592 (project freeciv):

I would suggest to assert there only if 2.2 is configured with --enable-debug
is enabled. Else, it will crash any normal client which connect an old server.
For 2.3, using fc_assert() seems good to prevent the client to crash in
classic configurations.


    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?16592>

_______________________________________________
  Message posté via/par Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to