URL:
  <http://gna.org/bugs/?16929>

                 Summary: compiled on debian testing just crashes on strlen 
                 Project: Freeciv
            Submitted by: None
            Submitted on: Friday 10/22/2010 at 22:28 CEST
                Category: general
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
             Assigned to: None
        Originator Email: m...@rldn.net
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: None
         Planned Release: 

    _______________________________________________________

Details:

i can build the server with no problem but when i run it the following error
occurs.  I have tried different versions of 2.2 this is from 2.2.1

(gdb) bt full
#0  0x000000000079cc70 in strlen@@GLIBC_2.2.5 ()
No symbol table info available.
#1  0x00000000004fb289 in real_mystrdup (str=0x56a389 "\003",
called_as=0x5480b3 "strdup", 
    line=1412, file=0x56a31b "shared.c") at mem.c:139
No locals.
#2  0x00000000004fc7bf in init_nls () at shared.c:1412
No locals.
#3  0x000000000040992e in srv_init () at srv_main.c:174
No locals.
#4  0x000000000040380c in main (argc=1, argv=0x7fffbe5421e8) at
civserver.c:187
        inx = <value optimized out>
        showhelp = <value optimized out>
        showvers = <value optimized out>
        option = <value optimized out>





    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?16929>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to