Follow-up Comment #41, bug #15559 (project freeciv):

I finally got around to trying Christian's patched Windows build on Windows
7. I compared it to 2.2.3.

There was no difference in behaviour in anything I tried (i.e., no
regression). Since the problem wasn't originally a Windows problem, I think
that's OK.

I tried:
* starting a local game from the client as normal: OK
* starting a separate server (no special arguments) and connecting to it from
** from GUI, to localhost:5556: OK
** from GUI, to _hostname_:5556 (as found by LAN scan): OK
*** (That's the first time I've ever seen the LAN scan work. It has never
worked at all for me on Linux. But that's another bug.)
** "-s -a": OK
** "-s -a": OK
** "-s ::1 -a": client crash(?), server sees nothing
** "-s fe80::ac36:49f3:cc39:4032%11 -a": ditto

I didn't have any luck trying to get the patched server to listen on an IPv6
address (::1, fe80::ac36:49f3:cc39:4032%11, fe80::ac36:49f3:cc39:4032). I
didn't try vanilla 2.2.3.

I think my Windows 7 installation must support IPv6 at some level, as "ping
localhost" displays "Pinging _hostname_ [::1]". However, I've done nothing
special to set it up (the machine wasn't even on a network when I tested
this). I'm not too worried.


Reply to this item at:


  Message sent via/by Gna!

Freeciv-dev mailing list

Reply via email to