URL:
  <http://gna.org/bugs/?17552>

                 Summary: error: ls_sqlite3.h: No such file or directory
                 Project: Freeciv
            Submitted by: dmarks
            Submitted on: Sat 22 Jan 2011 02:05:45 PM PST
                Category: None
                Severity: 3 - Normal
                Priority: 7 - High
                  Status: None
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: trunk r19073
         Discussion Lock: Any
        Operating System: None
         Planned Release: 

    _______________________________________________________

Details:

Recently in trunk, compilation fails with the following on my Kubuntu system.
I do have libsqlite3 packages installed.

script_fcdb.c:37:24: error: ls_sqlite3.h: No such file or directory
make[4]: *** [script_fcdb.lo] Error 1
make[4]: Leaving directory `/home/rdmarkstedt/fc/tr/server/scripting'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/rdmarkstedt/fc/tr/server/scripting'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/rdmarkstedt/fc/tr/server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rdmarkstedt/fc/tr'
make: *** [all] Error 2

Here's what configure reports:

****************** Configuration Summary ******************

  == General build options ==
  Shared libraries:      no
  Debugging support:     some
  Profiling support:     no
  IPv6 support:          yes

  == Client ==
  Build freeciv client:  yes

  Maintained client frontends:
    Gtk-2.0: yes
    SDL:     no
    Xaw:     no
    QT:      no
    Stub:    no

  Not maintained client frontends:
  (no guarantee that they even compile)
    Win32:   no
    FTWL:    no

  == Server ==
  Build freeciv server:  yes
    AI modules support:    no
    Database support:      no
      mysql:                 no
      postgres:              no
      sqlite3:               yes

I assume that it was introduced in patch #2114 but I haven't tested it. In
any case, regardless of the status of my sqlite environment, it's odd that
configure fails here despite the fact that "Database support" is disabled.




    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?17552>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to