Follow-up Comment #4, bug #17678 (project freeciv):
> I keep this ticket open as there were more problems. please
> report if some of them are still valid ...
I think you've fixed all the relevant ones in the savegame I was having
trouble with, thanks. I think you can close this ticket.
>> (Off-topic but: have I missed the point of
> The naming should be read as:
> compat_load_020400() - load pre 2.4.0 savegame
> compat_save_020400() - save pre 2.4.0 savegame
Ah, my mistake, sorry -- I read the comments and not the actual code. It
makes sense to me now.
> So perhaps the functions should be renamed and the original
> 2.3 version can be removed (set to NULL in the compat array).
I'm for keeping the names the same (if we ever invent compat_..._020301(),
say, then all the functionality currently in compat_..._020400() will need to
stay in the same function -- let's say the name means "translate data between
*previous* and _020400"). I've submitted patch #2523 which removes the
_020300() functions and attempts to explain the backward compatibility
strategy in comments (hopefully I've got it right this time...)
Reply to this item at:
Message sent via/by Gna!
Freeciv-dev mailing list