Update of bug #17962 (project freeciv):

         Planned Release:                         => 2.3.0,2.4.0            


Follow-up Comment #4:

Another data point:

User GM1350 on the forum, who's put together a number of large map scenarios
<http://forum.freeciv.org/viewtopic.php?t=6328>, reports in email that they
cannot load some of them in the Windows version of 2.3.0-beta3, but they can
load others (see thread). I think the examples mentioned were:
* europe-332x264-v1.8.sav.gz <http://forum.freeciv.org/download.php?id=1295>
* middleeast-400x300-v1.1.sav.gz
* earth-500x250-v1.0.sav.gz <http://forum.freeciv.org/download.php?id=1299>
* italy-420x300-v1.0.sav.gz <http://forum.freeciv.org/download.php?id=1300>
GM1350 writes: "If I use my maps (ex. Earth) and I select this map in
''Scenario Game'' (on Windows Vista).. I see this:

Starting server...
Welcome to the Freeciv version 2.3.0-beta3 (beta version) Server at port
You are logged in as 'Administrator' connected to Administrator.
Established control over the server. You have command access level 'hack'.
Administrator: 'set topology "WRAPX|ISO"'
Option: topology has been set to "Wrap East-West" and "Isometric"
Lost connection to server (read error)!

"But freeciv-server.rpt is white!"

Which seems to indicate that the server has crashed.

I haven't tried to work out in detail what's different between the reported
working and non-working ones. The non-working ones tend to have a larger
number of tiles, but there isn't a simple threshold in number of tiles that
says whether or not it'll work.

However, I have no trouble loading any of these scenarios on Ubuntu Linux
10.04.2 on x86_64 (64-bit), either in a client-spawned server or in a
standalone server (and I don't see any errors or warnings in the latter),
either with 2.3.0-beta3 or the head of S2_3.

Similarly, I have no trouble generating maps where size=90.

So it looks like we're dealing with a Windows-specific server crash, which is
a shame as I don't really know how to get good post-mortem diagnostics for

I guess it's also possible that it's an issue when Freeciv is compiled for
32-bit architectures -- some quantity that needs to be 64-bit is not? Can
someone confirm whether the above scenarios work when compiled for some 32-bit
Unix platform?

Possibly running valgrind on Linux will show something up; I haven't tried it


Reply to this item at:


  Message sent via/by Gna!

Freeciv-dev mailing list

Reply via email to