Follow-up Comment #3, patch #2529 (project freeciv):

This is much better first part. It's basically full patch except that one
macro call in gtk3-client.m4 must be changed when really switching to use gtk3
(AM_PATH_GTK_2_0 -> AM_PATH_GTK_3_0). Advantages over the previous division to
two patches are
- Smaller local patch to be used when testing real gtk3
- gtk2-client and gtk3-client will already have separate configure checks.
This is turn means:
  * Minimum gtk2-version can be set separately (i.e. correctly) for each
client
  * gtk3-client can be built without building gtk2-client

As this is basically full patch, I'll consider this ticket finished once this
patch goes in. The required macro change will be part of the ticket where
gtk2-client will turn from gtk2-program to gtk3-program.

(file #13171)
    _______________________________________________________

Additional Item Attachment:

File name: Gtk3ConfigurePartI_2529-2.diff Size:12 KB


    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?2529>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to