Follow-up Comment #12, bug #18200 (project freeciv):

That Makefile was very helpful, thank you. I noticed that it passes to
compiler some parameters that I cannot find from any gcc documentation. My
guess is that Mac OS gcc/g++ is modified special version, and you really need
that to use frameworks.
So to make configure *right* we should first check if compiler in use
supports frameworks at all.
Attached patch is more like quick hack to help testing what works and what
not. It tries to set number of options that the qmake generated Makefile
seemed to set, but not all of them.

(file #13215)
    _______________________________________________________

Additional Item Attachment:

File name: QtFrameworkDetect_18200-2.diff Size:1 KB


    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?18200>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to