URL:
  <http://gna.org/patch/?2724>

                 Summary: gtk3 freeciv-modpack
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Fri 17 Jun 2011 11:33:48 PM EEST
                Category: module installer
                Priority: 5 - Normal
                  Status: Ready For Test
                 Privacy: Public
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: 2.4.0

    _______________________________________________________

Details:

With attached patch freeciv-modpack can be built as gtk3-program. This is
based on configure checks without any user options (we probably want to add
some later, even though freeciv-modpack is just non-critical helper utility).
If suitable gtk3 development fils are found, freeciv-modpack is built as
gtk3-program. Failing that, it's built as gtk2-program if gtk2 development
files are found. Failing also that, it's not built at all.

We are lucky in that current freeciv-modpack sources are completely
compatible with both gtk2 and gtk3. We just have to set include paths to use
correct versions of gtk headers and to link against correct libraries.

I have tested this now only in a system where both gtk2 and gtk3 development
files are present, and it correctly produced binary linked against gtk3
libraries.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Fri 17 Jun 2011 11:33:48 PM EEST  Name: Gtk3FCMP.diff  Size: 3kB   By:
cazfi

<http://gna.org/patch/download.php?file_id=13257>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?2724>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to