Normally i would trim a response somewhat, but since i'm reanimating a 
thread that was presumed to  be long dead i felt it best to leave it all in.

        I managed to stumble upon a pair of gimmicks that worked, even if i 
didn't fully understand what they were doing. Those gimmicks are: A) a 
patchfile upon audio_sdl.c [attached] and patch script [perl -pi -e 
's|COC_SOUND, GUI_LAST, NULL|COC_SOUND, GUI_LAST, "sdl"|' client/options.c].  
These seemed to work fine until i tried them just now with 2.2.6  Anyway, 
neither of the patches is having the desired effect, so i'll probably get rid 
of them...

Attachment: freeciv.patch
Description: Binary data


        It seems to be a case in the past that the preferences file is by 
default set to no sound, and all that i previously needed to do was go to Game 
-> Options -> Local Client -> Sound and change 'none' to 'sdl'.  Now even 
though it already reads 'sdl', the new build makes no sound and always spits 
this out upon startup:

> David-Lowes-MacBook-Pro:~ (516) $ freeciv-gtk2
> 2: No real audio plugin present.
> 2: Proceeding with sound support disabled.
> 2: For sound support, install SDL_mixer
> 2: http://www.libsdl.org/projects/SDL_mixer/index.html

        I *do* have sdl-mixer [runtime and shared] 1.2.11 installed, though i 
haven't yet verified that any other programs are able to use it successful.  I 
need to get some sleep now and will do that tomorrow.  Meanwhile, am i off base 
in thinking that this is most likely a configuration issue?  

P.S.  If it's not too much trouble, i wouldn't mind receiving a copy of the 
port file used by macports [for comparison]...

On 20 Jun, 2010, at 8:27 PM, Daniel Markstedt wrote:

> Hi David,
> 
> Did you manage to sort this problem out?
> 
> It's working fine here on a 10.6.3 machine. All packages except
> SDL_mixer-1.2.9 (which was built through its own make script)
> installed through macports.
> 
> Not sure how to help you debug this, though.
> 
> Daniel
> 
> On Fri, Mar 26, 2010 at 9:55 AM, David Lowe <doctorjl...@verizon.net> wrote:
>>        Greetings!  I have assumed package maintainership for the freeciv 
>> package in the 'fink' build system for the Macintosh.  This is my first time 
>> for something like this, and i'm naturally in over my head.
>> 
>>        I'm hoping this is the appropriate forum for my question, if not i'd 
>> be glad of a suggestion for a better place.  I'm just about satisfied with 
>> my build of freeciv 2.2.0 for OSX, with the exception that i don't get the 
>> sound effects.  The only sound i hear from the game is the 'beep' at the 
>> beginning of a new turn.  I don't think there's anything different about my 
>> build, as Napoleon XIV's official build was similarly quiet.
>> 
>>        Details: i have libogg and SDL-mixer marked as dependencies, both the 
>> runtime and shared library portions.  Is there an intermediary package 
>> missing, or a configuration option?  My automated build system is setting 
>> configuration like so:
>> 
>>> ConfigureParams: <<
>>>   --mandir=%p/share/man \
>>>   --disable-sdltest \
>>>   --enable-client=gtk \
>>>   --disable-dependency-tracking \
>>>   --with-x \
>>>   
>>> PKG_CONFIG_PATH="%p/lib/pango-ft219/lib/pkgconfig:%p/lib/fontconfig2/lib/pkgconfig:%p/lib/freetype219/lib/pkgconfig:$PKG_CONFIG_PATH"
>>>  FREETYPE_CONFIG=%p/lib/freetype219/bin/freetype-config
>>> <<
>> 
>>        Where '%p' represents the standard installation directory, and 
>> --disable-sdltest is used to prevent configuration failure for remote 
>> builds.  I have verified that the stdsounds directory and 
>> stdsounds.soundspec are in the freeciv data directory.  What am i missing?
>> 
>> Sent from my MacBookPro
>> 
>> All those.. moments will be lost.. in time.. like.. tears.. in the rain..
>> _______________________________________________
>> Freeciv-dev mailing list
>> Freeciv-dev@gna.org
>> https://mail.gna.org/listinfo/freeciv-dev
>> 

Sent from my MacBookPro

"Am I going to die, doctor?"   "Trust me, it's the last thing you'll do."
_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to