URL:
  <http://gna.org/bugs/?19579>

                 Summary: Deprecated declarations compiler warnings
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Fri 23 Mar 2012 04:07:50 PM EET
                Category: client-gtk-3.0
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: Ready For Test
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: None
         Planned Release: 2.4.0, 2.5.0

    _______________________________________________________

Details:

Compiling gtk3-client, or gtk3-version of freeciv-modpack, causes warnings
about deprecated declarations on Ubuntu 12.04 beta. TRUNK and S2_4, as they
are the branches with gtk3-stuff, are affected.

We use some deprecated stuff on purpose, since we don't support only *latest*
gtk3, but older versions where now deprecated things were the only way to
achieve what was needed.
Attached patch simply disables the warning.




    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Fri 23 Mar 2012 04:07:50 PM EET  Name: WNoDeprDecl.diff  Size: 817B  
By: cazfi

<http://gna.org/bugs/download.php?file_id=15399>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?19579>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to