URL:
  <http://gna.org/bugs/?20240>

                 Summary: Recursive autosettler displacement causing it to
work current tile not detected
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Sat 13 Oct 2012 07:43:09 AM EEST
                Category: ai
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: Ready For Test
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: None
         Planned Release: 2.3.3, 2.4.0, 2.5.0

    _______________________________________________________

Details:

Autosettler A displacing B, B displacing C, and C displacing A can lead to A
start working on current tile. When control returns to original A handling
function, that case is not detected but it tries to continue handling from
where it left. In the particular case I encountered this resulted in adv_goto
complaining about unit having ACTIVITY_GEN_ROAD which it does not support.

Fix attached.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Sat 13 Oct 2012 07:43:09 AM EEST  Name: DisplaceToCurrentTile.patch 
Size: 718B   By: cazfi

<http://gna.org/bugs/download.php?file_id=16693>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?20240>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to