There is an intermittent problem that occurs with the government choice
window in the new Beta 2.4.0 version.  When the Statue of Liberty Wonder is
achieved, sometimes, but not always, the government choice window gets stuck
on just "revolution".  When selected, the government changes to "anarchy",
but from then on the government window does not show the drop down menu of
government selections, effectively forcing anarchy as the form of government
for the remainder of the game.  Further turns do nothing to help matters.  I
worked around the situation by reloading a saved game previous to completing
the Statue of Liberty wonder, then selected revolution to change from
"monarchy" to "democracy" after a period of revolt.  Thereafter, when the
wonder was completed, the government choices were available.


I've also played a second game from the start and completed the Statue of
Liberty wonder and moved immediately from "monarchy" to "democracy" and the
drop down menu of government selections worked fine so that the change was
without any period of revolt.  Since it doesn't occur with every game upon
completing the wonder, I describe it as an intermittent problem.  Not sure
of the cause, but thought it bore mentioning as part of the test of the new
Beta version.



Freeciv-dev mailing list

Reply via email to