On 21 January 2013 12:12, Marko Lindqvist <cazf...@gmail.com> wrote:
> What versions of autotools older distributions we may still want to
> support have?
>
> CentOS 5: autoconf 2.59 and automake 1.9.6
> CentOS 6: autoconf 2.63 and automake 1.11.1

My main machine is still on the oldest viable Ubuntu (10.04), which will
run out of security support in April, and that has 2.65-3ubuntu1 /
1.11.1-1.

The current stable Debian, squeeze (the only Debian still supported),
has 2.67-2 / 1.11.1-1+squeeze1. (And wheezy should be released any time
now?)

>  I'm ready to drop CentOS-5 support from freeciv-2.6, if not from
> freeciv-2.5 (and autotools are not needed when building from
> ready-made release tarball anyway).
  [...]
>  Given the new development on patch #3606, I'd say we're better to
> drop autoconf-2.59 support from TRUNK now. Support for it would be so
> kludgy anyway, that claiming it to be supported would be almost like
> lying. Better to honestly make minimum requirement greater. I'd say we
> go for autoconf-2.61 for 2.5 already, with no currently known needs to
> bump it further for 2.6.

I don't see any pressing need to keep support for 2.59, especially given
that it's developers / release managers rather than end users that need
it.
TBH I think we could drop it for 2.4 even, if we really wanted to.

_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to