On 3 May 2013 19:37, David Lowe <doctorjl...@verizon.net> wrote:

>
> I just compiled the 2.4.0-beta2 in Ubuntu 12.04.  I was a little surprised
> to find that it now requires curl, i thought that was not going in until
> 2.5?  If this is intentional, i will prepare a patch to INSTALL, which
> doesn't mention libcurl at all.
>

 Yes, it's in 2.4. Maybe you too have been following freeciv development
too long, different branches blurring :-) it was 2.3 branching after which
curl soon went in (2.3 is first one with freeciv-modpack, and thanks to
libcurl it works much more reliably in 2.4).

 It's mentioned in README.packaging and NEWS, but you are right that it
should be in INSTALL too. While at it, 2.5 & TRUNK version of INSTALL
should also mention that threading is not hard dependency (pthreads or
windows threads).


 - ML
_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to