URL:
  <http://gna.org/bugs/?21159>

                 Summary: 'mapimg colortest' causes assertion failures and
server disconnection
                 Project: Freeciv
            Submitted by: jtn
            Submitted on: Mon Sep 23 10:41:02 2013
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: Confirmed
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 2.4.0
         Discussion Lock: Any
        Operating System: GNU/Linux
         Planned Release: 2.4.1,2.5.0,2.6.0

    _______________________________________________________

Details:

Reported by Dox4242 on the forum
<http://forum.freeciv.org/f/viewtopic.php?f=8&t=145>, reproduced by me:

In a client-spawned server, '/mapimg colortest' in a running game leads to the
client/server connection being broken with the client saving 'Lost connection
to server (decoding error)!'

In a standalone server, doing '/mapimg colortest' pregame, there are loads of
assertion failures including repeats of the following, but the server stays
alive:


1: invalid index: 0 <= -1 < 20736
1: in img_index() [mapimg.c::1980]: assertion 'y >= 0 && y < pimg->imgsize.y'
failed.
1: Please report this message at http://gna.org/projects/freeciv/





    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?21159>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to