Summary: Rename 'is_available' property of nations to
Submitted by: jtn
Submitted on: Sat Nov 9 23:39:24 2013
Priority: 5 - Normal
Status: In Progress
Assigned to: jtn
Discussion Lock: Any
Planned Release: 2.5.0,2.6.0
While working on patch #3448, I found the member name 'is_available' a
misleading name for what it does. I've chosen 'is_pickable' as being possibly
a bit better ("Whether the client is allowed to try to pick the nation at game
Also, many comment updates regarding its use and related topics, particularly
its interaction with nation map start positions.
No functional change in this patch (except to some log_verbose() messages).
Reply to this item at:
Message sent via/by Gna!
Freeciv-dev mailing list