I cannot compile trunk:

cc1: warnings being treated as errors
registry_ini.c: In function ‘secfile_insert_include’:
registry_ini.c:1069: error: format ‘%lu’ expects type ‘long unsigned int’, but argument 4 has type ‘size_t’
make[3]: *** [registry_ini.lo] Error 1
make[3]: se sale del directorio «/home/jordi/freeciv/trunk/freeciv/utility»
make[2]: *** [all] Error 2
make[2]: se sale del directorio «/home/jordi/freeciv/trunk/freeciv/utility»
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio «/home/jordi/freeciv/trunk/freeciv»
make: *** [all] Error 2
jordi@ubuntu10-4:~/freeciv/trunk/freeciv$


And also I can't compile S2_5!!!

cc1: warnings being treated as errors
dataio.c: In function ‘dio_put_sint32’:
dataio.c:331: error: integer constant is too large for ‘long’ type
dataio.c: In function ‘dio_get_sint32’:
dataio.c:740: error: integer constant is too large for ‘long’ type
make[4]: *** [dataio.lo] Error 1
make[4]: se sale del directorio «/home/jordi/freeciv/S2_5/freeciv-2.5/common»
make[3]: *** [all-recursive] Error 1
make[3]: se sale del directorio «/home/jordi/freeciv/S2_5/freeciv-2.5/common»
make[2]: *** [all] Error 2
rm packets_generate
make[2]: se sale del directorio «/home/jordi/freeciv/S2_5/freeciv-2.5/common»
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio «/home/jordi/freeciv/S2_5/freeciv-2.5»
make: *** [all] Error 2
jordi@ubuntu10-4:~/freeciv/S2_5/freeciv-2.5$

This happens with Ubuntu 10.4 and gcc version 4.4.3.

This means that this are not a supported distribution now? It's too old?

Thanks


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to