URL:
  <http://gna.org/patch/?4413>

                 Summary: Warn if 2.3 or 2.4 ruleset uses negated = TRUE
effect requirement(s)
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Sun 05 Jan 2014 03:31:27 PM EET
                Category: general
                Priority: 5 - Normal
                  Status: Ready For Test
                 Privacy: Public
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: 2.3.5, 2.4.2

    _______________________________________________________

Details:

As discussed in bug #21115, this patch adds warning message to S2_4, and S2_3
for cases where ruleset uses effect requirement with negated = TRUE instead of
putting such requirements to separate nreqs list.

I should add to the earlier discussion that while it's unlikely that 2.4
ruleset authors would start using negated = TRUE requirements out of blue, I
can easily see this saving ourselves (freeciv maintainers) while backporting
patches from newer branches where negated/present field of requirements will
be used instead of nreqs list.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Sun 05 Jan 2014 03:31:27 PM EET  Name: NegatedWarning.patch  Size: 5kB  
By: cazfi

<http://gna.org/patch/download.php?file_id=19683>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?4413>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to