URL:
  <http://gna.org/bugs/?21474>

                 Summary: Windows gtk2-client accompanied by gtk3 modpack
installer
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Sun 12 Jan 2014 09:11:43 AM EET
                Category: bootstrap
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: In Progress
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: Microsoft Windows
         Planned Release: 2.4.2, 2.5.0, 2.6.0

    _______________________________________________________

Details:

In task #7681 cproc said:
> GTK+3 is used for the modpack installer in every package.

gtk2-client should be accompanied by gtk2 modpack installer, so it doesn't
need both gtk2 and gtk3 libraries included.

Also, gtk2 is still considered the default in S2_4.

In S2_5 and TRUNK it's possible to build gtk2 and gtk3 modpack installers
simultaneously (and executables will have distinct names). In S2_4 that's not
possible, which probably means that we cannot reliably provide different
modpack installers for S2_4 for each client package (what will happen if user
installs both gtk2- and gtk3-client)

So, in S2_4 target would be to always ship gtk2 modpack installer:
- The S2_4 default being gtk2.
- It won't bloat default gtk2-client with gtk3 libraries, but the experimental
gtk3-client with gtk2 libraries

In S2_5 target would be to provide modpack installer equivalent to client
frontend, with sdl-client using the default (gtk3) modpack installer.




    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?21474>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to