Follow-up Comment #2, patch #4558 (project freeciv):
This code is readable to me, and seems both sensible and useful in all sorts
of ways. I'd rather not see the universals_u in
unit_type_fulfills_requirement() named "arg", because I have to think about it
in the function call. Perhaps use "univ" or similar (as in
Personally, I'd rather see most of the enablement code moved to
requirements.c, as part of the interface, so that other cases where we want to
run boolean analysis inside a requirements iteration can be similarly
encapsulated (the AI wants to check stuff like this fairly often as well).
Reply to this item at:
Message sent via/by Gna!
Freeciv-dev mailing list