When running 'dllstack.sh' of crosser 0.12.1 on Ubuntu 14.04, I get the 
following error:

08.06 12:21 : Fetching autoconf version 2.69
08.06 12:21 : Unpacking autoconf version 2.69
08.06 12:21 : Configuring native-autoconf
08.06 12:21 : Building native-autoconf
08.06 12:22 : Fetching automake version 1.14
08.06 12:22 : Unpacking automake version 1.14
08.06 12:22 : Configuring native-automake
08.06 12:22 : Building native-automake
08.06 12:22 : Fetching libtool version 2.4.2
08.06 12:22 : Unpacking libtool version 2.4.2
08.06 12:22 : Patching libtool-2.4.2: libtool_bash.patch
08.06 12:22 : Configuring native-libtool
08.06 12:22 : Building native-libtool
08.06 12:23 : Fetching libffi version 3.0.13
08.06 12:23 : Unpacking libffi version 3.0.13
08.06 12:23 : Configuring native-libffi
08.06 12:23 : Building native-libffi
08.06 12:23 : Fetching glib version 2.38.2
08.06 12:23 : Unpacking glib version 2.38.2
08.06 12:23 : Configuring native-glib
08.06 12:23 : Configure for native-glib failed
Configure for native-glib failed
08.06 12:23 : Native build failed
Native build failed

------------------

stderr.log says:

**** native-glib ****
configure: error: Package requirements (libffi >= 3.0.0) were not met:

No package 'libffi' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBFFI_CFLAGS
and LIBFFI_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

------------------

I see that 'native-libffi' has just been installed in 
'~/.crosser/0.12.1/dllshost', but I'm not sure if 'native-libffi' is meant to
be used by 'native-glib' or if it is needed for something else and I need to 
install libffi from a Ubuntu package?


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to