Follow-up Comment #19, bug #18764 (project freeciv):

Some savegames from jimishol on Friday, and IRC log for context.

Once again, the Statue of Liberty is in play.


10:02 < jimishol> hi, there. it's almost my first game i try to play. and its
against normal AI . at gentoo testing linux. im pretty sure that at every turn
i checked if i had all governments available. i have spent several hours i
want to go it through the end but im facing this
http://civland.org/forum/viewtopic.php?f=20&t=118 Usually i loaded earliest
rounds and going from there but now it doesnt work for the last 5 rounds. does
anyone know how c
10:02 < jimishol> ould it be to quit when all is ok and on loading the last
round to have this government bug?
10:13 < jtn> jimishol: ergh. This is a known bug that we so far haven't been
able to track down: http://gna.org/bugs/?18764
10:13 < jtn> I don't have anthing to suggest, really, I'm afraid :(
10:14 < jtn> What version are you using, and what kind of client?
10:14 < jimishol> txs for replying. so everyone has it. is there a better work
around than mine?
10:15 < jtn> everyone has it> no, it's intermittent and hard to reproduce;
that's why we haven't tracked it down.
10:16 < jimishol> freeciv 2.4.2 giu-gtk-2.0 client
10:16 < jimishol> gui-gtk
10:19 < jimishol> i first noticed when changed to democracy but now it happens
all alone. the mystery is that since i closed it yesterday all was ok. upon
loading governments were missing without game acting at all
10:21 < jimishol> i found i game 18 rounds earlier that is ok :)
10:23 < jimishol> can i change goverment by hand? with some server command?
its not cheating since i have the liberty statue
10:32 < jtn> jimishol: the only thing I can think of is loading the game into
another client, if you have one available, change government, save, and
continue from there
10:32 < jtn> bit crap I know
10:33 < jtn> if you have a savegame that you can reproduce it from, can you
attach it to the ticket? Might help us track it down
10:33 < jtn> "reproduce it from"> the bug, I mean
10:36 < jimishol> hmmm, tried but sdl clients doesnt seem to work perhaps
against gnome-shell i use. no i cant reproduce i only have  saves that seems
ok. i will try to reproduce if i succeed i will contact here first. txs a lot
guys
10:42 < akfaew> what about editing the .sav?
10:48 < jimishol> i dont have target_government_name i only have
government_name="Democracy" I suggest when i have to change government i will
edit this one and reload. txs
10:49 < jimishol> im in Democracy but list of gov... is empty
10:51 < persia> jimishol: To confirm, if you save the game demonstrating the
bug, and reopen it, the bug is gone?
10:59 < jimishol> no , i have to load earlier rounds. At every round i had
full list of governments i mannually saved to a file i named 'still-ok' but
obviously didnt protected me since the still-ok yesterday , upon loading today
became STILL-BUG. and about 18 earlier rounds of autosave still have the bug
even if i checked them yesterday and saved them manually too on 'still-ok' . i
will reboot. to see if 'still-ok' is still ok,
11:14 < jimishol> no reboot didnt help
11:15 < persia> So the problem isn't about the save files particularly, but
something about the state of the client?  The same savefile can have or not
have the bug?
11:16 < jimishol> but this time one of sdl client worked. i seek the option to
see the govverments
11:25 < jimishol> well i didnt found the list of goverments BUT as i said i
loaded with sdl client, that worked this time, the 'still-ok' file and i saved
it at once it saved as freeciv-T0270-Y01790-manual.sav.bz2
11:26 < jimishol> i opened it with gui-gtk and list WAS there
11:26 < persia> That's...odd.  Hrmmm.
11:26 < persia> Well, glad to hear you got your game back :)
11:27 < jimishol> if i open freeciv-T0270-Y01790-auto.sav.bz2 or
still-ok.sav.bz2 they produce the bug. i open freeciv-T0270-Y01790-manual and
its ok
11:27 < jtn> first one to track this bug down gets virtual cookie
11:28 < jtn> when I got closest, its presence depended on whether my
completely unrelated instrumentation was compiled in
11:28 < jimishol> should i upload the auto.sav that has the bug and manual.sav
that created by sdl client and is ok?
11:28 < jtn> jimishol: Can't hurt.


(file #21125, file #21126, file #21127)
    _______________________________________________________

Additional Item Attachment:

File name: freeciv-T0270-Y01790-auto.sav.bz2 Size:53 KB
File name: freeciv-T0270-Y01790-manual.sav.bz2 Size:54 KB
File name: still-ok.sav.bz2               Size:54 KB


    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?18764>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to