URL:
  <http://gna.org/bugs/?22320>

                 Summary: Lua compilation tries to use _setjmp() when
configure has only checked _longjmp()
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Sat 12 Jul 2014 10:40:28 PM EEST
                Category: bootstrap
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: Ready For Test
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: None
         Planned Release: 2.4.3, 2.5.0, 2.6.0

    _______________________________________________________

Details:

IRC:

Begasus: but I still see Haiku having a problem with the declaration for
_setjmp in luaconf.h


----

ldo.c uses _setjmp() (in addition to _longjmp() ) in a code guarded by
LUA_USE_ULONGJMP, which we set in localluaconf.h when HAVE__LONGJMP is defined
by configure.

Attached fix makes LUA_USE_ULONGJMP to depend on both HAVE__LONGJMP and
HAVE__SETJMP.




    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Sat 12 Jul 2014 10:40:28 PM EEST  Name: _SetJmpCheck.patch  Size: 1kB  
By: cazfi

<http://gna.org/bugs/download.php?file_id=21379>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?22320>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to