URL:
  <http://gna.org/patch/?4937>

                 Summary: Really assert tech is in valid range
                 Project: Freeciv
            Submitted by: persia
            Submitted on: Sun 13 Jul 2014 07:03:36 AM JST
                Category: general
                Priority: 5 - Normal
                  Status: Ready For Test
                 Privacy: Public
             Assigned to: persia
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: 2.4.3, 2.5.0, 2.6.0

    _______________________________________________________

Details:

The advance_required() assert that appears to intend to check that the
provided ID is within the valid range always returns TRUE when A_NONE <
A_LAST, so doesn't actually check anything useful.  Changing logical OR to
logical AND makes the test properly check the range.



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Sun 13 Jul 2014 07:03:36 AM JST  Name:
really-assert-tech-is-in-valid-range.patch  Size: 795B   By: persia

<http://gna.org/patch/download.php?file_id=21382>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?4937>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to