URL:
  <http://gna.org/bugs/?22481>

                 Summary: Server port failures not giving proper error message
                 Project: Freeciv
            Submitted by: cazfi
            Submitted on: Sat 16 Aug 2014 05:16:56 AM EEST
                Category: general
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: Ready For Test
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 
         Discussion Lock: Any
        Operating System: None
         Planned Release: 2.4.4, 2.5.0-beta2, 2.6.0

    _______________________________________________________

Details:

>From bug #22448

> 0: bind failed: The operation completed successfully.

One problem here is that error message is not telling what went wrong. It
should not be "The operation completed succesfully" but some failure message.
This is typical "getting errno when it's already overridden" -problem.

Fix attached.




    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Sat 16 Aug 2014 05:16:56 AM EEST  Name: Eno.patch  Size: 1kB   By: cazfi

<http://gna.org/bugs/download.php?file_id=21745>

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?22481>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to