URL:
  <http://gna.org/bugs/?22504>

                 Summary: Client cannot start local server (Ubuntu 14)
                 Project: Freeciv
            Submitted by: rcasha
            Submitted on: Fri 22 Aug 2014 07:15:42 AM UTC
                Category: general
                Severity: 3 - Normal
                Priority: 5 - Normal
                  Status: None
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
                 Release: 2.4.2-1
         Discussion Lock: Any
        Operating System: GNU/Linux
         Planned Release: 

    _______________________________________________________

Details:

Pressing "Start new game" or "Load game" on the client fails because it cannot
start the server. On screen, the following status messages are shown:

Starting local server...
Couldn't connect to the server
We probably couldn't start it from here.
YTou'll have to start one manually. sorry...

In the log file, the following lines are added:

This is the server for Freeciv version 2.4.2
You can learn a lot about Freeciv at http://www.freeciv.org/
3: in log_init() [log.c::231]: log started
0: in server_open_socket() [sernet.c::1146]: bind failed: Address already in
use
0: bind failed: Address already in use

However, netstat -ln does not show port 5556 in use.

I am using Ubuntu 14.04.1 LTS
I have disabled AppArmor - same result.

Any suggestions?




    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?22504>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to