URL:
  <http://gna.org/patch/?5153>

                 Summary: [metaticket] Socket binding / listening problems
when starting server
                 Project: Freeciv
            Submitted by: jtn
            Submitted on: Sat 30 Aug 2014 14:20:59 BST
                Category: None
                Priority: 7 - High
                  Status: None
                 Privacy: Public
             Assigned to: None
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: 

    _______________________________________________________

Details:

We've got a number of outstanding reports where the client fails to start a
server, and/or a server fails to start standalone, with "bind failed" or
similar network errors.

These are spread across various platforms and branches, and we have different
socket arrangements on different branches.

This metaticket is to try to keep all the distinct reports straight.

* Pre 2.4.2:
** WinXP on 2.4.0 (mentioned in bug #22549). Will probably ignore unless it
sheds light on other reports.
* 2.4.2/2.4.3 (relevant changes in 2.4.2: bug #19720, bug #21547, patch
#4471):
** Windows: bug #22549 (client-spawned, two reports)
*** We hope bug #22463 has helped, but no data yet
** Linux (Ubuntu): bug #22504 (client-spawned); also Debian 757876
* S2_5 (a relevant change in 2.5.0-beta1: bug #21583 [remove SO_REUSEADDR]):
** Windows: bug #22448

Reporting issues that hinder diagnosis (all fixed, none released as of
2.4.3/2.5.0-beta1): bug #22481, bug #22503, bug #22462.




    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?5153>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to