Follow-up Comment #5, bug #22602 (project freeciv):

> Please upgrade compiler to 4.6.X at least and warnings will go 
> away.
If we're going to have a minimum GCC version that we support with
--enable-debug, we should probably document it in INSTALL or similar.

Perhaps "configure" could detect old GCC and disable -Werror with
--enable-debug if detected?
Otherwise old GCC users can't use --enable-debug, which we recommend as a
diagnostic sometimes.

    _______________________________________________________

Reply to this item at:

  <http://gna.org/bugs/?22602>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to