On 09/22/2016 02:26 PM, Dietmar wrote:
> Hi,
>
> I realized, my last unattended upgrade was on 8-Sept. So I went via
> ssh into the box and tried aptitude which recommended me to do a "sudo
> dpkg --configure -a", which brought up an error:
>
>> $ sudo dpkg --configure -a
>> libapt-inst2.0:armhf (1.3~rc4) wird eingerichtet ...
>> Trigger für libc-bin (2.23-5) werden verarbeitet ...
>> dpkg: Fehler beim Bearbeiten des Paketes apt (--configure):
>>  Paket ist in einem sehr schlechten inkonsistenten Zustand - Sie sollten es
>>  nochmal installieren, bevor Sie die Konfiguration versuchen.
>> Fehler traten auf beim Bearbeiten von:
>>  apt
> "apt is in a very bad shape, you should reinstall it bevor trying to
> configure"
> So I did an "apt update", which ran through, checked that there were a
> couple of packages to upgrade, including apt from 1.3~rc2 to 1.3~rc4.
> The "apt upgrade" produced again some errors:
>> $ sudo apt upgrade
>> Paketlisten werden gelesen... Fertig
>> Abhängigkeitsbaum wird aufgebaut.       
>> Statusinformationen werden eingelesen.... Fertig
>> Probieren Sie »apt-get -f install«, um dies zu korrigieren.
>> Die folgenden Pakete haben unerfüllte Abhängigkeiten:
>> E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.
> meaning "unfullfilled dependencies, try "-f". 
> Before breaking my packages, is it save to use "force"?
> Also, what might have caused this, just a bug in "apt"?
>
> I am running on testing.
>

I think it's this issue mentioned in the changelog for apt:

* re-add apt breaks/replaces apt-utils (<< 1.3~exp2~) (Closes: #836220 
<https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=836220>)

I would try "apt-get -f install", and you may also need to do "apt-get
install --reinstall apt".

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Freedombox-discuss mailing list
Freedombox-discuss@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/freedombox-discuss

Reply via email to