Hi!

     Was:

______________O\_/_________________________________\_/O______________
int EnableHMA(VOID)
[...]
  _DisableA20();

#ifdef DEBUG
  if (fmemcmp(MK_FP(0x0000, 0x0000), MK_FP(0xffff, 0x0010), 128) != 0)
_____________________________________________________________________
              O/~\                                 /~\O

Now:

______________O\_/_________________________________\_/O______________
int EnableHMA(VOID)
[...]
  _DisableA20();

#ifdef DEBUG
  if (!checkHMA())
_____________________________________________________________________
              O/~\                                 /~\O

Should be: "if (checkHMA())". To make code more clear (understandable),
better to name this function as "checkHMApresent()".




-------------------------------------------------------
This SF.Net email is sponsored by: Oracle 10g
Get certified on the hottest thing ever to hit the market... Oracle 10g. 
Take an Oracle 10g class now, and we'll give you the exam FREE.
http://ads.osdn.com/?ad_id=3149&alloc_id=8166&op=click
_______________________________________________
Freedos-kernel mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/freedos-kernel

Reply via email to