Posted a question on the kernel list about a problem with undefined
symbols while
trying to compile the kernel sources with turbo c.  I didnt get a
reply and meanwhile continued mess about with the compile.
Found in the kernel source docs folder the file build.txt which listed
the open watcom files needed for a dos version of watcom.  Downloaded those
files and it built the kernel successfully.  Then got the freecom sources and
found that the default compiler was turbo c++  tcpp101.zip.    After some
fumbling again was able to build the freecom sources using tcpp101.zip.

Went back and repeated the build of the kernel sources with turbo c  tc201.zip
and this time the build was ok.  I have written up some detailed instructions
and thought to mention a few things here.

I believe that the link problem with unresolved symbols was related to
mixing up some binaries from tc201.zip and tcpp101.zip.  By installing the
two compilers in different directories, the problem has not reoccurred.

I tried the stable and unstable kernel sources and had a minor problem
with stable.  Didnt pursue and used unstable instead.  

shell =c:\command.com  c:\    /E:1024  /P /MSG    
or shellhigh and the options variations havent tried but need to 
have this in config.sys, otherwise build errrors out with messages 
Can not set environment variable  `  `
Environment full?
Compilation aborted

Freecom source compile was unsuccessfull until I downloaded
com82pl3.zip  and  suppl.zip.   At the moment I am not sure if 
if the other combined source file has a problem or not. 

The tc++  compiler must be in the system path    c:\zzz\tcc101\bin
to compile freecom, build will fail in an obvious way if not

Havent downloaded the cpp files from open watcom so do not know if it
is possible to compile freecom with watcom.  I may start looking into it.


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_idt77&alloc_id492&op=click
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to