The config files where kinda rush written. But I think it's fine enough
if you just read them and see what the purpose of them was (like not
loading the packet driver and such). This way you will have enough memory.

Again, try to remove as many device driver / TSR as possible. In doubt
and if you don't know what it does deactivate it. DOS doesn't need
drivers, just for games PCI soundcard drivers, mouse and CD-ROM addons
are needed.

With the sbeset utility you can change the virtual irq, dma and so on.
It works for my sb live, should work probable for you too.

Use nssi to see all irq's and your sound setup and maybe try to set the
virutal irq from 5 to 7 or so. Restart and use sbecfg to check.

Heart of China works well with SB Live, I had a short try. Space Quest V
isn't abandonedware.

-mr

Elrich2k3 schrieb:
> After messing with SET BLASTER and SBPCI.INI for a while, I managed to get
> digital sound working.. at least according to SBTEST.EXE -- And it does work
> in a few games [Quest For Glory IV, Disk ver., at least] --- but others give
> me the generic "Unable to initialize audio hardware" [Space Quest V] or the
> hopefully more helpful "Unable to initialize the sound driver! Sound card
> interrupt is already in use by another card." [Heart of China]
> 
> Trying to fix this, I edited autoexec.bat and sbpci.ini to set both MT32 and
> SB16 emulation to I7, but got the same error message. So I put MT32 on I5
> and SB16 on I7... and still got the same error message.
> 
> 
> Michael Reichenbach wrote:
>> I told you in my previous mail not to use anything else then classic
>> himem.exe and classic emm386.exe! For me them are the most compatible
>> ones.
>>
> 
> I've tried all three now, and all work -- but plain HIMEM and EMM386 crashed
> on me when I tried to load a couple of Sierra's install programs with the
> sound drivers working.
> 
> 
> Michael Reichenbach wrote:
>> This did differ a bit from your set blaster variable before.
>>
> 
> Yes, I noticed and fixed that when I woke up earlier.
> 
> I suppose this setup is fine... until I manage to find an old Motherboard
> with an ISA slot, and a SB16, on eBay, and have money.
> 
> FDCONFIG.SYS is loading only the lines that were default prefixed with "!",
> and:
> DEVICE=C:\JEMDOS\JEMMEX.EXE SB
> SHELLHIGH=C:\FDOS\bin\command.com C:\FDOS\bin /E:1024 /P=C:\autoexec.bat
> 
> Yes, I tried HIMEMX+JEMM386, and there was no difference, and tried
> HIMEM+EMM386, which crashed on me a couple of times. Autoexec is set to
> 
> SET BLASTER=A220 I5 D1 T6 P330 H7
> 
> And I tried T4 and T1, and the other things I mentioned above.
> 
> Also I tried using your entire FDCONFIG and AUTOEXEC you posted, but FreeDOS
> wouldn't even load with it. I noticed a few typos that I fixed, but it still
> wouldn't load.



-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Freedos-user mailing list
Freedos-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/freedos-user

Reply via email to