Mateusz -- Thank you for the repository.  I've downloaded some updates, and am 
running JEMM386 now.


Eric -- Great to meet you, and thank you for all the good work on FreeDOS!


I tried 4DOS, and found that most of the trouble I'd been having was due to 
memory management
not having been customized for the machine.  Once I got the memory management 
I could change back to FreeCOM and it was stable.  The whole process was a lot 
setting up Quarterdeck's extended memory manager -- you have to do a lot of 
and crashing to get it right, but once it's right it's not only stable but 
there's LOTS
of memory available!


I've got FreeDOS on four machines now.  Three of them are good and stable, one 
has some
reproducible problems.


It worked right out of the box on an Intel D845WN, P4/1.70 GHz, 1GB RAM, 40 GB 


I'm running it on Virtual PC 2007 under Windows XP on a laptop with a Pentium M.
It crashed at first, but it's now solid as a rock with this line in 
The NOEMS is optional.  NOINVLPG was written by Japheth specifically for this 
The X=CC00-CFFF was arrived at through testing by trial and error.


I haven't had a lot of time to test the Compaq Armada with the Pentium 2,
but I'm going to assume it's stable until it does something to prove otherwise.
It works with no upper memory.  I'm experimenting with making a small section of
upper memory available, but haven't had time to follow through on this.


Then there's the Pentium 3 I mentioned in my last message.  It still doesn't 
work right.


I have removed all LOADHIGH/DEVICEHIGH/SHELLHIGH, and set JEMM386 to 
so everything I'm doing now should be happening in conventional memory only!

I can reliably generate a crash by running HELP.EXE.
Most of the time JEMM386 catches it with a general protection fault message 
like this:

   Jemm386: exception 0D occured at CS:EIP=218F:00002C42, ERRC=00000000
   SS:ESP=3AE3:00000D6A EBP=00000D6E EFL=00033207 CR0=80000011 CR2=00000000
   EAX=00000004 EBX=00000002 ECX=00000004 EDX=00003392 ESI=0000FFFF EDI=00000008
   DS=215F ES=617D FS=217F GS=115E [CS:IP]=F3 A5 73 01 A4 8E DA 8B
   Press ESC to abort program


The segment of code at [CS:IP] is indeed from HELP.EXE (after decompressing it)
and AFAIK it only occurs in one place.

It's a REP MOVSW instruction for moving words.
If you look at the source SI and the destination DI, the source is set to FFFF
which means it's about to overflow the segment.


When FreeCOM is loaded and I crash HELP.EXE, it causes the behavior you 
mentioned where
internal commands work and external ones like EDIT just return a command prompt.
Another thing that happens is that if I try internal commands that refer to 
it tells me it can't access the files, even though DIR shows the files to exist.
COPY CON FILE.TXT does this.


I'll be glad to do further testing on this.

Please let me know if there's any kind of tool I can run on my computer
that would help to determine what is causing this trouble.




I mentioned a very unimportant bug involving the F3 key.
The F3 key is supposed to get the last line, if available.
In most kinds of DOS, when you press the F3 key at the very first commant 
prompt, nothing happens
because there is no "last line" available.
In 4DOS it beeps because there is no last line available.
In FreeCOM it prints garbage characters, and it does this on all four computers.
This bug isn't a big deal because it goes away as soon as you enter the first 
command line,
but it does indicate that something is wrong.




Again, please let me know if there's any further testing I can do
now that I can reliably create a particular type of trouble in conventional 
memory on one system.

 - - Shane 

Subject: Command prompt returns without commands executing
Date: Sun, 8 Mar 2009 06:40:01 -0700

I'm a computer technician, and am interested in FreeDOS because I often perform 
low-level operations on large disks (copying data, fixing file structures.)  So 
far I'm impressed with FreeDOS -- it seems to have all the important features 
of the commercial DOSses, and the fact that it's currently being developed is a 

Unfortunately, I've got the same problem on two completely different machines, 
and I can't find any reference to it except for a post on last 
year that was never answered.

I'm using the FreeDOS 1.0 distribution CD for developers.

When I push F3 immediately after booting, garbage characters display.

When FreeDOS has been running for a while, the command prompt will return 
without the command executing.  Rebooting will "fix" this for a while.

I tried eliminating all use of high memory and UMB.  The problem persists.
Not loading a memory manager can make the problem take longer to occur.
I can't isolate the problem to a particular line in FDCONFIG.SYS or FDAUTO.BAT.

I tried using Rugxulo's floppy distribution (disk 1) which is based on a later 
kernel -- no difference.

The first computer is a tower with an Intel SE440BX2 mainboard, P3/550, 256 MB 
RAM, and an 80GB drive with a 40GB FAT32 partition.

The second computer is a Compaq Armada 3500 notebook, P2/366, 128 MB RAM, 6GB 
HDD with FAT32.

Both computers run Windows 98SE just fine.  The disks were originally formatted 
with Windows 98 SE.  They now boot to MetaKern.  The tower passes MEMTEST86.

There's not a lot on the internet about this, but I can't be the only one this 
has happened to!

Any help would be appreciated.

 - - Shane

Express your personality in color! Preview and select themes for HotmailĀ®. See 
Express your personality in color! Preview and select themes for HotmailĀ®.
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial.
Freedos-user mailing list

Reply via email to