Blair Campbell wrote:
Chris: Guess I didn't include enough details of the question. I run Ubuntu
8.04 and then Dosemu My printer, a HP Officejet K80xi works fine in
linux for both text and graphical files (I just enter lpr filename and
either file prints fine with no further input on my part). After I enter
FreeDos, I can only print text files. If I could enter some magical command
from within dos that executed any linux command, the problem would be
solved. Soooo, my question is "Does such a command exist?".

AFAIR, Dosemu includes a utility that can execute unix commands from
within dosemu.  You should check the dosemu documentation.
Bob T.

Blair: Thanks for the help! I found the right documentation finally: the file "dosemu.list" lists all (?) dosemu files and their paths. Specifically /usr/lib/dosemu/drive_z/dosemu/ This file is neat: it is a tree struckture of where each file is located.

Anyhow I printed "unix lpr ~/Dosprog/roses.jpg" and "unix lpr -p -o cpi=10 -o lpi=6 ~/Dosprog/TXT" where TXT is a text file. Conclusion: both .jpg files and fancy detaied printing of text files works great. Thanks again -- Bob T.
Come build with us! The BlackBerry(R) Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
Freedos-user mailing list

Reply via email to