Hi, quick reply,

On Sat, Jul 30, 2011 at 10:05 AM, JPT <j.p...@gmx.net> wrote:
> Rugxulo, you are right, I should do this in a more structured way.
> expected to throw the CD in, and thats it.
> EDIT: current status is:
> - hardware ok, maybe the memory was faulty, i have to verify this.
> - freedos 1.1 successfully installed.
> - Debian installer is currently downloading addtional packages.
> next steps, as soon as debian is working:
> - install additional dos packages
> - make network work
> Details of what I have done yet:
> hardware
> - CPU and board should be rocking stable, had XP running for years
> without probs.

Sounds good.

> - memory...
> Was 3x128 + 1x256 = 640, but recognized only 384 MB. This might indicate
> a problem. Removed all but 1x128 MB. Memtest runs fast now,
> 20 mins for 2 passes. Everything ok.
> I will reinsert and check some of the other memory modules later.
> (I did memtest before without error, but who knows...)

Hope no problems there, but lacking any reason to worry, I guess it's
fine.   ;-)

> - disk, ontrack is running, 2h.
> No error.

Does this computer's BIOS need it?? Shouldn't it be new enough to not
need it? (Well, I just blindly assume you know otherwise.)

> I have my rescue floppies and CDRWs always at hand, but the labels
> aren't matching the content any more, for most of them :)

Yeah, I have too many (usually unlabeled) floppies, heheh.   ;-)

> - CPU clock rate too high for a lot of old dos software?
> Do you think clocking down to below 500 Mhz might help?
> Bart says so for his network boot floppy.

Hard to imagine for "normal" stuff, but it depends. Some games are
pickier than others. Other stuff (TP7 unpatched) might also complain.

> - A20 stuff...
> especially the XMS/EMS driver loading seems to fail often.

It shouldn't. At least XMS should "just work". EMM386 is quirky, so
I'm not too too surprised there.

> I have in mind that A20 has to do something with EMS oder XMS. (or UMB?)
> And, A20 is some hack using the keyboard controller.
> Since I attached an USB keyboard to a USB switch, for easily switching
> between computers... could this be a problem, eg in the BIOS USB
> Keyboard code?

It could indeed be a USB keyboard / BIOS conflict. Try unplugging it
(if you can) and seeing if that helps.

> Now to the software.
> - This time I partitioned and formatted the drive before booting the
> installer.
> btw, the fdisk program contained on the floppy sucks.

I assume you mean FD FDISK 1.31? A la "looks like classic MS" one?

> created a bad partition layout. have to move partitions now...

What exactly does that mean? You had a pre-existing one that it
corrupted? (I hope we're using "latest" 1.31 here.) TestDisk can
sometimes recover lost partitions.

Otherwise, we might need to add a tool to backup the MBR / partition
table before mucking with it. (IIRC, both WDE and BOOTMGR can do so if
you tell them to manually.)

> what about xfdisk instead?

Already in the works (right, Bernd?). There's also SPFDISK, which is
allegedly better for SATA, but that one's SF site seems to have

> - Install debian... for having less trouble with partitioning in the
> future, and to verify the hardware.

Sounds good, you don't need to hog the whole drive with FreeDOS anyways.   ;-)

> - install Freedos 1.1T3
> Ran through in almost no time, wow!

Yeah, it's not including everything and the kitchen sink (for now),
just the basics.

> I got the same error message from Jemm, but pressing ESC continued
> booting the installer.

I do wonder what is being used there. Hopefully "X=TEST I=TEST" in
particular. We've got to be careful on newer computers, might even
want to do "X=E000-EFFF". (Ideally, there should be a "safe" and/or
"no EMS" option in CONFIG.SYS.)

> So where do you suggest to continue? Should I jump to the 1.0 installer?
> or should I install manually?

Manually is fine if you can workaround the partition issues you mentioned.

> Could you point me to a tutorial for
> manual install, or is it just "unpack anywhere", as we are used from old
> dos?

fdisk (create FAT on primary active partition)
sys a: c:
install whatever else you want / need

> - network
> its a 3c905b. It should work using the NDIS driver included with Barts
> Network Boot Disk. Does it work with freedos out of the box or do I have
> to do this manually using this wiki page?
> http://sourceforge.net/apps/mediawiki/freedos/index.php?title=Networking_FreeDOS_-_NDIS_driver_installation

Most likely manually. Ugh, all that networking stuff is extremely
confusing (to me), but hopefully someone else here can guide you

But try this packet driver:


> Which cards are known to be working? Got a few Realtek based somewhere...

Pretty much whatever Crynwr has (see above).

> Regarding your other questions.
>> "Production" meaning what? Dunno, not sure it's been verified for
>> military use.   ^_^
> well, we are still using an old 486 with DOS 5 for some special hardware
> and software (which partly was ported from apple II a long time ago)


> since the 14" monitor broke down yesterday and the 200 MB harddrive
> broke down half a year ago...


Oh well, it had a good life.

> we have to go to slighly newer hardware
> that is able to run at least a linux, and has got some interfaces for
> backup.

Slightly newer? Linux (2.6+) prefers 128+ MB RAM nowadays!

>> It would also help to know what big apps you've tried (or primarily
>> want) to run, just to know what you expect to work.
> I need:
> - pascal compiler

TP55 (16-bit) is freeware (w/ free registration)
GPC and FPC (32-bit) are GPL

> - maybe basic compiler or interpreter

FD 1.0 had a BWBASIC (16-bit) .EXE interpreter, GPL
FBC (32-bit) is GPL
SmallBASIC, Brandy, XST (all 32-bit) also exist

> - maybe fortran compiler, if the old software has to be recompiled

Latest DJGPP is GCC 4.6.1 (F2003/2008), but OpenWatcom 1.9 also supports F77.

> - network would be nice

Sounds like your card probably works (see above packet driver).

> - some basic linux tools, eg vim, df, du, dd, wget...

VIM provides a DPMI (32-bit DJGPP) .EXE these days, e.g. 7.3.
Other *nix tools are at DJGPP archive (fil41b + txt20b + shl2011b =
GNU Coreutils).
FD 1.0 had WGET binary.

>> EDIT: Oh yeah, you'd need working network, that's kinda arcane. But if
>> it works (by some miracle) ....
> ehm, so network won't work?    :(

It might work, but keep in mind that most companies don't write packet drivers.

> Well, so far for now. I continue with debian install...
> Thanks for all that help!

Hope it actually does help.   :-/

Got Input?   Slashdot Needs You.
Take our quick survey online.  Come on, we don't ask for help often.
Plus, you'll get a chance to win $100 to spend on ThinkGeek.
Freedos-user mailing list

Reply via email to