24.01.2014, 03:05, "Eric Auer" <e.a...@jpberlin.de>:


 I do not use EMM386 (JEMMX has been loaded with NOEMS option).

The NOEMS option just means "do not reserve 64 kB EMS 3 page
frame area so more UMB space is free". You can still use EMS
4 calls (which need no page frame). Also, importantly, JEMMEX
always uses protected mode, NOEMS option or not. And in that
mode, JEMMEX always simulates the A20 gate visible from DOS,
because the real A20 gate is only switched on once and then
left on by JEMMEX... So it still behaves differently towards
your hardware compared to HIMEM, XMGR or similar drivers :-)

Right. I did it in wrong way with NOEMS option while trying to fight with HIMEMX and XMGR problems on AMD :)



You have interesting ports and tools :-) CURL, FlashROM,
getargs, NVRAM, PCIutils, watt32, ZLIB, a tiny binary
OpenWatcom patch (what does it patch?)...

This patch for DOS32/A to avoid some annoying messages from DOS32/A during startup. I'm too lazy to recompile DOS32/A from sources :) Plan to update FlashROM sources to the latest one and possible CURL too if it will be compiled within OW.


          I can try to load FreeDOS from USB stick instead of PXE.

      That might also be interesting, yes.

 You mean like via RUFUS (bare bones) install?      http://rufus.akeo.ie/
 Something like that but running from Linux.

Maybe my sys-freedos-linux is interesting for you then. It is
basically a script to compile a FreeDOS boot sector for a FAT
style of your choice and put it on a disk or diskimage. Other
steps (copy kernel etc. to the disk) can be done without extra
tools because Linux supports FAT anyway. The script definitely
is not very automatic and you may need to provide extra params
manually but you sound experienced enough to figure out... Feel
free to ask questions about it. Note that depending on BIOS etc
you may want to partition the USB stick and/or put a bootable
MBR or boot menu as well. For example syslinux, grub, grub4dos.

I'll take a look on it. Thanks for the link. It might be intrested. For the current setup I run "qemu -ncurses" to install system from bootable disk to my own.
In my environment I've tried to boot grub4dos from Linux kernel via "kexec". It doesn't work well. My target is to get "iPXE" boot from Linux via "kexec". I've spent several days to update it's kernel header and stuck fighting with protected mode stuff. Something has scrambbled a data before or during self unpack of iPXE. Just a several sections are properly copied/unpacked, but the biggest one lead to crash. I've tried to debug it within IDA Pro and BOCHS emulator. I'm too young to have enough experience of A20/PM programming :) My DOS experience started in time of Win 3.x, DOS-6.2 and Novell 3.12. I've programming only in "user-space" those days, so I lack of enough PM knowledge here.
Anton D. Kachalov

CenturyLink Cloud: The Leader in Enterprise Cloud Services.
Learn Why More Businesses Are Choosing CenturyLink Cloud For
Critical Workloads, Development Environments & Everything In Between.
Get a Quote or Start a Free Trial Today. 
Freedos-user mailing list

Reply via email to