It turns out that mpxplay was not hanging as I thought.  It was instead 
taking 30 seconds to load.

It turns out further that the precise format of the BLASTER variable is 
important here.  The Media Vision installer created SET BLASTER=A220 D1 
I5 H3 T4.  But mpxplay was choking on the fact that D1 was before I5.  
When I edited the string to SET BLASTER=A220 I5 D1 H3 T4 instead, the 
player loaded in a second or two!


So now all I need to do is get a CD player working.

On 6/2/2015 3:16 PM, John Hupp wrote:
> I have sound working now with a Media Vision Jazz16 card (aka Pro 
> Sonic 16, an ISA PNP card) and DOOM, setting up the game to use the 
> card's SoundBlaster emulation feature.
> The Jazz directory also has a playfile.exe utility and a few test 
> WAV's, and these work.
> But so far I have gotten nowhere with playing mp3's or CD's.  I'm 
> starting with some apps that worked for me under FreeDOS 0.9 and/or 1.0.
> Mpxplay just hangs the system immediately, before anything appears 
> onscreen.  I downloaded the MPXP160D.ZIP version.
> Likewise I have not gotten any audio CD player to work.  I tried ACP 
> and CD-V (v19) so far.  ACP's screen appears with a track list, but 
> hitting enter to to start Playing the first track does nothing. CD-V 
> simply generates an "Invalid media!" error.  (I could add that the CD 
> setup is fine for data CD's.)
> Are there tips/tricks to get mpxplay to work?  What about a CD player 
> that's known to work with FD 1.1?
> I'm using a default FD 1.1 setup and selecting the first menu item at 
> boot.

Freedos-user mailing list

Reply via email to