I found out that ipconfig usage is not as expected for the DOS client.  
"Ipconfig /all" is meaningless. In my case, the one and only good 
command is "ipconfig c:\net."

This then reports (now again under DHCP), an IP address, gateway, and 
DNS server as expected.  But it reports "Lease Expired."  Even after I 
forced the router to give it a brand new lease on a different IP, it 
still reports the lease expired.  The router shows the lease as freshly 
issued with a day to live.

The date and time are correct on client and server.

Ideas?  (And no, "ipconfig /release" or "ipconfig /renew" won't work 
either.  They too are meaningless.)

On 6/15/2015 12:19 PM, John Hupp wrote:
> I just tried changing the DOS client from DHCP to static 
> configuration, and I still get the same net use error.
> Furthermore "ipconfig /all" still reports "No DHCP data available."  
> Shouldn't it report my static configuration info?
> On 6/15/2015 11:46 AM, John Hupp wrote:
>> Fundamentals -- you may be onto something.  Though TCP/IP 
>> initialization completes without error, running "ipconfig /all" 
>> yields "No DHCP data available." I get the same result from two 
>> identical cards, both configured the same way.
>> I do note that both cards are old non-PNP ISA cards, which I thought 
>> would be appropriate for this vintage rig.
>> In the meantime, in the Registry I changed 
>> HKLM\SYSTEM\CurrentControlSet\Control\Lsa\LMCompatibilityLevel=3 –> 
>> 0, which is "Send LM & NTLM responses" per 
>> https://technet.microsoft.com/en-us/library/jj852207%28v=ws.10%29.aspx. 
>> Then I rebooted.  But I still get the same error on the DOS client.
>> @ Roberto Fazzalari: I have been avoiding your approach to date since 
>> I never had more than a rank novice's acquaintance with Wireshark.  
>> But it may be that I'll have to get reacquainted!
>> On 6/15/2015 12:09 AM, Louis Santillan wrote:
>>> Be sure that you have a good IP, gateway, and DNS setting from your 
>>> DHCP server.

Freedos-user mailing list

Reply via email to