Some off these patches have been knocking around for a while.

Who will hoover them up please?

This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.

Lee Jones (26):
  drm/mediatek/mtk_disp_color: Strip incorrect doc and demote header
  drm/mediatek/mtk_disp_gamma: Strip and demote non-conformant
    kernel-doc header
  drm/mediatek/mtk_disp_ovl: Strip and demote non-conformant header
  drm/mediatek/mtk_disp_rdma: Strip and demote non-conformant kernel-doc
    header
  drm/sti/sti_hdmi_tx3g4c28phy: Provide function names for kernel-doc
    headers
  drm/sti/sti_hda: Provide missing function names
  drm/sti/sti_tvout: Provide a bunch of missing function names
  drm/sti/sti_hqvdp: Fix incorrectly named function 'sti_hqvdp_vtg_cb()'
  drm/msm/disp/dpu1/dpu_encoder_phys_cmd: Remove unused variable
    'cmd_enc'
  drm/msm/disp/dpu1/dpu_hw_interrupts: Demote a bunch of kernel-doc
    abuses
  drm/msm/disp/dpu1/dpu_plane: Fix a couple of naming issues
  drm/msm/msm_gem: Demote kernel-doc abuses
  drm/msm/dp/dp_catalog: Correctly document param 'dp_catalog'
  drm/msm/dp/dp_link: Fix some potential doc-rot
  drm/nouveau/nvkm/subdev/mc/tu102: Make functions called by reference
    static
  drm/amd/display/dc/dce/dce_transform: Remove superfluous
    re-initialisation of DCFE_MEM_LIGHT_SLEEP_CNTL,
  drm/xlnx/zynqmp_disp: Fix incorrectly named enum
    'zynqmp_disp_layer_id'
  drm/xlnx/zynqmp_dp: Fix incorrectly name function 'zynqmp_dp_train()'
  drm/ttm/ttm_tt: Demote non-conformant kernel-doc header
  drm/panel/panel-raspberrypi-touchscreen: Demote kernel-doc abuse
  drm/panel/panel-sitronix-st7701: Demote kernel-doc abuse
  drm/vgem/vgem_drv: Standard comment blocks should not use kernel-doc
    format
  drm/exynos/exynos7_drm_decon: Fix incorrect naming of
    'decon_shadow_protect_win()'
  drm/exynos/exynos_drm_ipp: Fix documentation for
    'exynos_drm_ipp_get_{caps,res}_ioctl()'
  drm/vboxvideo/hgsmi_base: Place function names into headers
  drm/vboxvideo/modesetting: Provide function names for prototype
    headers

 .../drm/amd/display/dc/dce/dce_transform.h    |  3 +-
 drivers/gpu/drm/exynos/exynos7_drm_decon.c    |  2 +-
 drivers/gpu/drm/exynos/exynos_drm_ipp.c       |  4 +--
 drivers/gpu/drm/mediatek/mtk_disp_color.c     |  3 +-
 drivers/gpu/drm/mediatek/mtk_disp_gamma.c     |  4 +--
 drivers/gpu/drm/mediatek/mtk_disp_ovl.c       |  3 +-
 drivers/gpu/drm/mediatek/mtk_disp_rdma.c      |  4 +--
 .../drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c  |  4 ---
 .../gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c | 32 +++++++++----------
 drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c     |  4 +--
 drivers/gpu/drm/msm/dp/dp_catalog.c           |  2 +-
 drivers/gpu/drm/msm/dp/dp_link.c              |  6 ++--
 drivers/gpu/drm/msm/msm_gem.c                 |  4 +--
 .../gpu/drm/nouveau/nvkm/subdev/mc/tu102.c    |  6 ++--
 .../drm/panel/panel-raspberrypi-touchscreen.c |  2 +-
 drivers/gpu/drm/panel/panel-sitronix-st7701.c |  2 +-
 drivers/gpu/drm/sti/sti_hda.c                 |  6 ++--
 drivers/gpu/drm/sti/sti_hdmi_tx3g4c28phy.c    |  4 +--
 drivers/gpu/drm/sti/sti_hqvdp.c               |  2 +-
 drivers/gpu/drm/sti/sti_tvout.c               | 18 +++++------
 drivers/gpu/drm/ttm/ttm_tt.c                  |  2 +-
 drivers/gpu/drm/vboxvideo/hgsmi_base.c        | 19 +++++++----
 drivers/gpu/drm/vboxvideo/modesetting.c       | 20 +++++++-----
 drivers/gpu/drm/vgem/vgem_drv.c               |  2 +-
 drivers/gpu/drm/xlnx/zynqmp_disp.c            |  2 +-
 drivers/gpu/drm/xlnx/zynqmp_dp.c              |  2 +-
 26 files changed, 80 insertions(+), 82 deletions(-)

Cc: Adam Jackson <a...@redhat.com>
Cc: Ajay Kumar <ajaykumar...@samsung.com>
Cc: Akshu Agarwal <aks...@gmail.com>
Cc: Alex Deucher <alexander.deuc...@amd.com>
Cc: Alistair Popple <apop...@nvidia.com>
Cc: amd-...@lists.freedesktop.org
Cc: AngeloGioacchino Del Regno <angelogioacchino.delre...@somainline.org>
Cc: Benjamin Gaignard <benjamin.gaign...@linaro.org>
Cc: Ben Skeggs <bske...@redhat.com>
Cc: Ben Widawsky <b...@bwidawsk.net>
Cc: Chandan Uddaraju <chand...@codeaurora.org>
Cc: Christian Koenig <christian.koe...@amd.com>
Cc: "Christian König" <christian.koe...@amd.com>
Cc: Chun-Kuang Hu <chunkuang...@kernel.org>
Cc: Daniel Vetter <dan...@ffwll.ch>
Cc: David Airlie <airl...@linux.ie>
Cc: dri-de...@lists.freedesktop.org
Cc: Eric Anholt <e...@anholt.net>
Cc: Fabien Dessenne <fabien.desse...@st.com>
Cc: freedreno@lists.freedesktop.org
Cc: Hans de Goede <hdego...@redhat.com>
Cc: Harry Wentland <harry.wentl...@amd.com>
Cc: Huang Rui <ray.hu...@amd.com>
Cc: Hyun Kwon <hyun.k...@xilinx.com>
Cc: Inki Dae <inki....@samsung.com>
Cc: Jagan Teki <ja...@amarulasolutions.com>
Cc: Joonyoung Shim <jy0922.s...@samsung.com>
Cc: Krishna Manikandan <mkri...@codeaurora.org>
Cc: Krzysztof Kozlowski <krzysztof.kozlow...@canonical.com>
Cc: Kuogee Hsieh <khs...@codeaurora.org>
Cc: Kyungmin Park <kyungmin.p...@samsung.com>
Cc: Laurent Pinchart <laurent.pinch...@ideasonboard.com>
Cc: Leo Li <sunpeng...@amd.com>
Cc: linaro-mm-...@lists.linaro.org
Cc: linux-arm-ker...@lists.infradead.org
Cc: linux-arm-...@vger.kernel.org
Cc: linux-media...@lists.infradead.org
Cc: linux-me...@vger.kernel.org
Cc: linux-samsung-...@vger.kernel.org
Cc: Marek Szyprowski <m.szyprow...@samsung.com>
Cc: Matthias Brugger <matthias....@gmail.com>
Cc: Mauro Rossi <issor.or...@gmail.com>
Cc: Michal Simek <michal.si...@xilinx.com>
Cc: nouv...@lists.freedesktop.org
Cc: Philipp Zabel <p.za...@pengutronix.de>
Cc: Rob Clark <robdcl...@gmail.com>
Cc: Sam Ravnborg <s...@ravnborg.org>
Cc: Sean Paul <s...@poorly.run>
Cc: Seung-Woo Kim <sw0312....@samsung.com>
Cc: Stephen Boyd <swb...@chromium.org>
Cc: Sumit Semwal <sumit.sem...@linaro.org>
Cc: Thierry Reding <thierry.red...@gmail.com>
Cc: Vincent Abriou <vincent.abr...@st.com>
-- 
2.31.1

_______________________________________________
Freedreno mailing list
Freedreno@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/freedreno

Reply via email to