Hi Harsha,
Can you please give a backward compatibility patch similar to
the one you did for freetalk?

Hi Ray, Let me make a new release supporting both Guile 1.6 and 1.8.

Thanks,
--
Anand Babu Periasamy
GPG Key ID: 0x62E15A31
Blog [http://ab.freeshell.org]
The GNU Operating System [http://www.gnu.org]
Z RESEARCH Inc [http://www.zresearch.com]



Ray Van Dolson wrote:
Hi all, I'm packaging freehoo (and subsequently libyahoo2) for Fedora
and Fedora EPEL.  Ran into a small issue that I wanted to run by you
guys if anyone actually is susbscribed to this list still.. :)

The latest version of freehoo (3.5.0) appears to require guile 1.8.x to
build correctly.  Trying to build against an older version (1.6.x is
included with RHEL4) fails.  A lot of the errors look like they might
be corrected by some simple defines:

  http://www.bludgeon.org/~rayvd/rpms/freehoo/make.log

My other options include creating a guile18 package for EPEL4, using an
older version of freehoo (which might mean I'd need to use an older
version of libyahoo2 as well?) or just not providing an RPM fo anything
older than EPEL5 (RH5 and newer).

Any suggestions?

My initial releases are here:

  http://www.bludgeon.org/~rayvd/rpms/freehoo/
  http://www.bludgeon.org/~rayvd/rpms/libyahoo2/

libyahoo2 already had a .spec file, so I basically used it, but stuck
with their original sources and merged in your patches.

Anyways, if anyone is alive back there it'd be great to get some
feedback on this.

Thanks,
Ray


_______________________________________________
Freehoo-devel mailing list
Freehoo-devel@nongnu.org
http://lists.nongnu.org/mailman/listinfo/freehoo-devel


_______________________________________________
Freehoo-devel mailing list
Freehoo-devel@nongnu.org
http://lists.nongnu.org/mailman/listinfo/freehoo-devel

Reply via email to