On ti, 18 heinä 2017, Tomas Krizek via FreeIPA-devel wrote:
Hi,

builds

sssd-1.15.3-0.beta.5.fc27 and
libldb-1.2.0-1.fc27

caused a segfault when starting sssd service. I removed these builds
from copr. Instead, I added libldb-1.1.31-1.fc27, which is required by
samba.
Please do not do that! Return them back.

You should remove sssd-1.15.3-0.201703... from your system instead.
We removed it from the repo because dnf thinks it is of a higher version
than 0.beta.5.fc27. Technically, it is true in rpm comparisons but SSSD
guys are unwilling to fix their versioning scheme for a single wrongly
named sssd build in freeipa copr repo.

So we just need to ensure 1.15.3-0.201703... build does not exist on
your system.

If you've already installed these packages from freeipa-master copr and
have encountered this issue, please downgrade them.
No. Unfortunately, now you broke way more than before.

Samba 4.7 requires libldb 1.2.0 for correct functioning. We rebuild SSSD
1.15.3-0.beta.5.fc27 against this libldb version and everything is
working just fine.

Please return proper builds back to the repo.

--
/ Alexander Bokovoy
_______________________________________________
FreeIPA-devel mailing list -- freeipa-devel@lists.fedorahosted.org
To unsubscribe send an email to freeipa-devel-le...@lists.fedorahosted.org

Reply via email to