John Dennis wrote:
This adds a new dependency on python-lxml. It also requires that
python-nss be the current version (0.8). This is needed for the http
authentication work I did for Jason which was added in a recent
version of python-nss. This patch also fixes a deprecation warning
concerning nssinit() which is dependent on a newer version of
python-nss.

To the best of my knowledge both python-lxml and python-nss.0-8 are
currently available in the RHEL5 IPA compose, they are both
definately available in fedora F-11, F-12, rawhide.
---
From: John Dennis <jden...@redhat.com>
Subject: [PATCH] Require current versions of python-nss & python-lxml


 ipa.spec.in         |    3 ++-
 ipapython/nsslib.py |    2 +-
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/ipa.spec.in b/ipa.spec.in
index ce2c0a6..659a76a 100644
--- a/ipa.spec.in
+++ b/ipa.spec.in
@@ -173,7 +173,8 @@ Requires: python-kerberos >= 1.1-3
 Requires: authconfig
 Requires: gnupg
 Requires: pyOpenSSL
-Requires: python-nss
+Requires: python-nss >= 0.8
+Requires: python-lxml
%description python
 IPA is an integrated solution to provide centrally managed Identity (machine,
diff --git a/ipapython/nsslib.py b/ipapython/nsslib.py
index 05b45c1..2052843 100644
--- a/ipapython/nsslib.py
+++ b/ipapython/nsslib.py
@@ -95,7 +95,7 @@ class NSSConnection(httplib.HTTPConnection):
         if not dbdir:
             raise RuntimeError("dbdir is required")
- ssl.nssinit(dbdir)
+        nss.nss_init(dbdir)
         ssl.set_domestic_policy()
         nss.set_password_callback(self.password_callback)


I guess I forgot to send an e-mail about this. I acked and pushed it on Nov 23rd.

rob

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to