John Dennis wrote:
Who wrote our script and why?

Why aren't we using autoreconf instead?

FWIW is seriously broken, it's getting incorrect results when comparing different versions of tools. It thinks 1.7 is newer than 1.11 because it's doing string comparisons which causes it to run the wrong versions of some of the tools. I can fix the version comparison but my inclination is not to bother since autogen scripts have been replaced by the autoreconf tool. As for testing the minimum required tool version; is there an actual problem being solved by this?

I forget the details but it dates back to the origins of the project, perhaps there was a problem with autoreconf back then.

The autotools often blow themselves up which may be the reason for requiring a minimum. I remember a problem in libtool where it didn't work on Solaris 64-bit in something like versions 1.5.10 - 1.5.20, was fixed in 1.5.21, then broke again in 1.5.22. Lots of fun.

So if you want to replace it or fix it plesae do.


Freeipa-devel mailing list

Reply via email to